aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-05-23 23:28:42 +0000
committerGerrit Code Review <gerrit@lix-systems>2024-05-23 23:28:42 +0000
commit00bf2b105d677461bda0a5ba9b29bedb350c1eb1 (patch)
treeba1c87c6385655da6ce9336a2bf79423cf5c2a62 /tests/unit/meson.build
parent9530b7f2b2b653fc11753ce452636896350324ff (diff)
parenta0172dc81bff7f0665de77e771919e2e0b554788 (diff)
Merge changes I462a8cf0,I3b0bcea3,I2acd56e7,Ifc149764,I9e2ef170 into main
* changes: docs: linkify nix3-build mention in nix-build.md build: make internal-api-docs PHONY cleanup lookupFileArg add docstring to lookupFileArg add libcmd test for lookupFileArg
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index a997a0d56..35a11a5d3 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -212,3 +212,30 @@ test(
protocol : 'gtest',
verbose : true,
)
+
+libcmd_tester = executable(
+ 'liblixcmd-tests',
+ files('libcmd/args.cc'),
+ dependencies : [
+ liblixcmd,
+ liblixutil,
+ liblixmain,
+ liblixexpr,
+ liblixstore,
+ gtest,
+ boost,
+ ],
+)
+
+test(
+ 'libcmd-unit-tests',
+ libcmd_tester,
+ args : tests_args,
+ env : {
+ # No special meaning here, it's just a file laying around that is unlikely to go anywhere
+ # any time soon.
+ '_NIX_TEST_UNIT_DATA': meson.project_source_root() / 'src/nix-env/buildenv.nix',
+ },
+ suite : 'check',
+ protocol : 'gtest',
+)