aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorjade <lix@jade.fyi>2024-10-09 20:37:16 +0000
committerGerrit Code Review <gerrit@localhost>2024-10-09 20:37:16 +0000
commit7f7a38f2788ba7fa46cf38127f525700cf63e153 (patch)
tree70981196e35b96114d2d92129b62dba7d586e3be /tests/unit/meson.build
parent0012887310f24283e8a9ca08e0c2a49219ea4ff5 (diff)
parent345e3d068a7f3eb37bb795a38572ae06213a8341 (diff)
Merge changes Ib27cb43d,I03687b8b into main
* changes: testsuite: override NIX_CONF_DIR and NIX_USER_CONF_FILES Remove some outdated `make test` invocation suggestions
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index 8b0c66dd8..04fdf62a7 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -12,7 +12,11 @@
# It's only ~200 lines; better to just refactor the tests themselves which we'll want to do anyway.
default_test_env = {
- 'ASAN_OPTIONS': 'detect_leaks=0:halt_on_error=1:abort_on_error=1:print_summary=1:dump_instruction_bytes=1'
+ 'ASAN_OPTIONS': 'detect_leaks=0:halt_on_error=1:abort_on_error=1:print_summary=1:dump_instruction_bytes=1',
+ # Prevents loading global configuration file in /etc/nix/nix.conf in tests 😱
+ 'NIX_CONF_DIR': '/var/empty',
+ # Prevent loading user configuration files in tests
+ 'NIX_USER_CONF_FILES': '',
}
libutil_test_support_sources = files(