aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-03-21 15:38:11 -0600
committereldritch horrors <pennae@lix.systems>2024-03-26 00:43:33 +0100
commite1ffe56793be79dfea203121ecafff3d0baa29ba (patch)
treed337477251bc4187820ba0388c63e1c4d6a9c5f5 /tests/unit/meson.build
parentd3d7489571baeb651d3843dba3b638621694c174 (diff)
meson: implement unit tests
Unit tests can be run with `meson test -C build --suite check`. `--suite check` is optional, as right now that's the only test suite, but when functional tests are added those will be in a separate suite. Change-Id: I7f22f1cde4b489b3cdb5f9a36a544f0c409fcc1f
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build207
1 files changed, 207 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
new file mode 100644
index 000000000..a2e882098
--- /dev/null
+++ b/tests/unit/meson.build
@@ -0,0 +1,207 @@
+# NOTE(Qyriad): This file is one big slab of boilerplate.
+# Lix's current unit test organization is scattered and entagled.
+# Each of the test-support libraries could theoretically be a somewhat self-contained
+# subdir(), but literally nothing else can. Each of the tests have dependencies on other
+# test support libraries, and so do their support libraries.
+# Each of the tests have dependencies on their own andother test support libraries,
+# and so do their support libraries, and they have entangled dependencies on Lix's mainline
+# lib* targets as well.
+# The only boilerplate reduction I really could do here is throw everything in big nested dictionaries
+# and dynamically generate and refer to targets based on abstracted specs, but without user-defined
+# functions, the result would be way less readable than just a bit of copypasta.
+# It's only ~200 lines; better to just refactor the tests themselves which we'll want to do anyway.
+
+libutil_test_support_sources = files(
+ 'libutil-support/tests/cli-literate-parser.cc',
+ 'libutil-support/tests/hash.cc',
+ 'libutil-support/tests/terminal-code-eater.cc',
+)
+libutil_test_support = library(
+ 'nixutil-test-support',
+ libutil_test_support_sources,
+ dependencies : [
+ liblixutil,
+ # TODO(Qyriad): libutil tests really should not depend on libexpr...
+ liblixexpr,
+ rapidcheck,
+ boehm,
+ ],
+ include_directories : include_directories('libutil-support', '../../src'),
+)
+liblixutil_test_support = declare_dependency(
+ include_directories : include_directories('libutil-support'),
+ link_with : libutil_test_support,
+)
+
+libutil_tests_sources = files(
+ 'libutil/canon-path.cc',
+ 'libutil/chunked-vector.cc',
+ 'libutil/closure.cc',
+ 'libutil/compression.cc',
+ 'libutil/config.cc',
+ 'libutil/git.cc',
+ 'libutil/hash.cc',
+ 'libutil/hilite.cc',
+ 'libutil/json-utils.cc',
+ 'libutil/logging.cc',
+ 'libutil/lru-cache.cc',
+ 'libutil/pool.cc',
+ 'libutil/references.cc',
+ 'libutil/suggestions.cc',
+ 'libutil/tests.cc',
+ 'libutil/url.cc',
+ 'libutil/xml-writer.cc',
+)
+
+libutil_tester = executable(
+ 'libnixutil-tests',
+ libutil_tests_sources,
+ dependencies : [
+ rapidcheck,
+ gtest,
+ boehm,
+ liblixutil,
+ liblixexpr,
+ liblixutil_test_support,
+ ],
+)
+
+test(
+ 'libutil-unit-tests',
+ libutil_tester,
+ args : tests_args,
+ env : {
+ '_NIX_TEST_UNIT_DATA': meson.project_source_root() / 'tests/unit/libutil/data',
+ },
+ suite : 'check',
+ protocol : 'gtest',
+ verbose : true,
+)
+
+libstore_test_support_sources = files(
+ 'libstore-support/tests/derived-path.cc',
+ 'libstore-support/tests/outputs-spec.cc',
+ 'libstore-support/tests/path.cc',
+)
+
+libstore_test_support = library(
+ 'nixstore-test-support',
+ libstore_test_support_sources,
+ dependencies : [
+ liblixutil_test_support,
+ liblixutil,
+ liblixstore,
+ rapidcheck,
+ boehm,
+ ],
+ include_directories : include_directories(
+ 'libstore-support',
+ ),
+)
+liblixstore_test_support = declare_dependency(
+ include_directories : include_directories('libstore-support'),
+ link_with : libstore_test_support,
+)
+
+libstore_tests_sources = files(
+ 'libstore/common-protocol.cc',
+ 'libstore/derivation.cc',
+ 'libstore/derived-path.cc',
+ 'libstore/downstream-placeholder.cc',
+ 'libstore/machines.cc',
+ 'libstore/nar-info-disk-cache.cc',
+ 'libstore/outputs-spec.cc',
+ 'libstore/path.cc',
+ 'libstore/references.cc',
+ 'libstore/serve-protocol.cc',
+ 'libstore/worker-protocol.cc',
+)
+
+libstore_tester = executable(
+ 'libnixstore-tests',
+ libstore_tests_sources,
+ dependencies : [
+ liblixstore_test_support,
+ liblixutil_test_support,
+ liblixstore,
+ liblixutil,
+ rapidcheck,
+ gtest,
+ ],
+)
+
+test(
+ 'libstore-unit-tests',
+ libstore_tester,
+ args : tests_args,
+ env : {
+ '_NIX_TEST_UNIT_DATA': meson.project_source_root() / 'tests/unit/libstore/data',
+ },
+ suite : 'check',
+ workdir : meson.project_source_root(),
+ protocol : 'gtest',
+ verbose : true,
+)
+
+libexpr_test_support_sources = files(
+ 'libexpr-support/tests/value/context.cc',
+)
+
+libexpr_test_support = library(
+ 'nixexpr-test-support',
+ libexpr_test_support_sources,
+ dependencies : [
+ liblixstore_test_support,
+ liblixstore,
+ liblixutil,
+ liblixexpr,
+ rapidcheck,
+ ],
+ include_directories : include_directories(
+ 'libexpr-support',
+ ),
+)
+liblixexpr_test_support = declare_dependency(
+ include_directories : include_directories('libexpr-support'),
+ link_with : libexpr_test_support,
+)
+
+libexpr_tests_sources = files(
+ 'libexpr/derived-path.cc',
+ 'libexpr/error_traces.cc',
+ 'libexpr/flakeref.cc',
+ 'libexpr/json.cc',
+ 'libexpr/primops.cc',
+ 'libexpr/search-path.cc',
+ 'libexpr/trivial.cc',
+ 'libexpr/value/context.cc',
+ 'libexpr/value/print.cc',
+)
+
+libexpr_tester = executable(
+ 'libnixexpr-tests',
+ libexpr_tests_sources,
+ dependencies : [
+ liblixexpr_test_support,
+ liblixstore_test_support,
+ liblixstore,
+ liblixutil,
+ liblixexpr,
+ liblixfetchers,
+ rapidcheck,
+ boehm,
+ gtest,
+ ],
+)
+
+test(
+ 'libexpr-unit-tests',
+ libexpr_tester,
+ args : tests_args,
+ env : {
+ '_NIX_TEST_UNIT_DATA': meson.project_source_root() / 'tests/unit/libexpr/data',
+ },
+ suite : 'check',
+ protocol : 'gtest',
+ verbose : true,
+)