aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-06-19 22:12:24 -0600
committerQyriad <qyriad@qyriad.me>2024-06-20 13:56:53 -0600
commitfd250c51ed14132d79eb1329a4e679d41174e5b8 (patch)
treecc972149df96537cac32c88c1818d2fe8a1bb824 /tests/unit/meson.build
parente44dcd63c4d96807536cdcf2afb688a537cce9be (diff)
add a basic libmain test for the progress bar rendering
Hooray for leaky abstraction allowing us to test this particular part of the render pipeline. Change-Id: Ie0f251ff874f63324e6a9c6388b84ec6507eeae2
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index c3eefeede..9f19e5fd9 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -249,3 +249,25 @@ test(
suite : 'check',
protocol : 'gtest',
)
+
+libmain_tester = executable(
+ 'liblixmain-tests',
+ files('libmain/progress-bar.cc'),
+ dependencies : [
+ liblixmain,
+ liblixexpr,
+ liblixutil,
+ liblixstore,
+ gtest,
+ boost,
+ ],
+ cpp_pch : cpp_pch,
+)
+
+test(
+ 'libmain-unit-tests',
+ libmain_tester,
+ args : tests_args,
+ suite : 'check',
+ protocol : 'gtest',
+)