aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/manual/meson.build')
-rw-r--r--doc/manual/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/manual/meson.build b/doc/manual/meson.build
index 1bdbba77e..f53d41b5d 100644
--- a/doc/manual/meson.build
+++ b/doc/manual/meson.build
@@ -20,6 +20,8 @@ conf_file_json = custom_target(
capture : true,
output : 'conf-file.json',
env : nix_env_for_docs,
+ # FIXME: put the actual lib targets in here? meson have introspection challenge 2024 though.
+ build_always_stale : true,
)
nix_conf_file_md_body = custom_target(
@@ -50,6 +52,8 @@ nix_exp_features_json = custom_target(
command : [ nix, '__dump-xp-features' ],
capture : true,
output : 'xp-features.json',
+ # FIXME: put the actual lib targets in here? meson have introspection challenge 2024 though.
+ build_always_stale : true,
)
language_json = custom_target(
@@ -57,6 +61,8 @@ language_json = custom_target(
output : 'language.json',
capture : true,
env : nix_env_for_docs,
+ # FIXME: put the actual lib targets in here? meson have introspection challenge 2024 though.
+ build_always_stale : true,
)
nix3_cli_json = custom_target(
@@ -64,6 +70,8 @@ nix3_cli_json = custom_target(
capture : true,
output : 'nix.json',
env : nix_env_for_docs,
+ # FIXME: put the actual lib targets in here? meson have introspection challenge 2024 though.
+ build_always_stale : true,
)
generate_manual_deps = files(