aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/src/contributing/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/manual/src/contributing/meson.build')
-rw-r--r--doc/manual/src/contributing/meson.build17
1 files changed, 15 insertions, 2 deletions
diff --git a/doc/manual/src/contributing/meson.build b/doc/manual/src/contributing/meson.build
index 2929578c8..8c76a6206 100644
--- a/doc/manual/src/contributing/meson.build
+++ b/doc/manual/src/contributing/meson.build
@@ -4,12 +4,25 @@
experimental_feature_descriptions_md = custom_target(
command : nix_eval_for_docs + [
'--expr',
- 'import @INPUT0@ (builtins.fromJSON (builtins.readFile @INPUT1@))',
+ 'import @INPUT0@ "experimental" "xp" (builtins.fromJSON (builtins.readFile @INPUT1@))',
],
input : [
- '../../generate-xp-features.nix',
+ '../../generate-features.nix',
xp_features_json,
],
capture : true,
output : 'experimental-feature-descriptions.md',
)
+
+deprecated_feature_descriptions_md = custom_target(
+ command : nix_eval_for_docs + [
+ '--expr',
+ 'import @INPUT0@ "deprecated" "dp" (builtins.fromJSON (builtins.readFile @INPUT1@))',
+ ],
+ input : [
+ '../../generate-features.nix',
+ dp_features_json,
+ ],
+ capture : true,
+ output : 'deprecated-feature-descriptions.md',
+)