aboutsummaryrefslogtreecommitdiff
path: root/docker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'docker.nix')
-rw-r--r--docker.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/docker.nix b/docker.nix
index 2a13c23fb..ffb553f78 100644
--- a/docker.nix
+++ b/docker.nix
@@ -137,11 +137,8 @@ let
name = "root-profile-env";
paths = defaultPkgs;
};
- profile = pkgs.buildPackages.runCommand "user-environment" { } ''
- mkdir $out
- cp -a ${rootEnv}/* $out/
-
- cat > $out/manifest.nix <<EOF
+ manifest = pkgs.buildPackages.runCommand "manifest.nix" { } ''
+ cat > $out <<EOF
[
${lib.concatStringsSep "\n" (builtins.map (drv: let
outputs = drv.outputsToInstall or [ "out" ];
@@ -161,6 +158,11 @@ let
]
EOF
'';
+ profile = pkgs.buildPackages.runCommand "user-environment" { } ''
+ mkdir $out
+ cp -a ${rootEnv}/* $out/
+ ln -s ${manifest} $out/manifest.nix
+ '';
in
pkgs.runCommand "base-system"
{