aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 8f93127f7..792387da4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -152,8 +152,6 @@
}
);
- binaryTarball = nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix; };
-
overlayFor =
getStdenv: final: prev:
let
@@ -236,13 +234,11 @@
);
# Perl bindings for various platforms.
- perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.perl-bindings);
+ perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.perl-bindings);
# Binary tarball for various platforms, containing a Nix store
# with the closure of 'nix' package.
- binaryTarball = forAllSystems (
- system: binaryTarball nixpkgsFor.${system}.native.nix nixpkgsFor.${system}.native
- );
+ binaryTarball = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.binaryTarball);
# docker image with Lix inside
dockerImage = lib.genAttrs linux64BitSystems (system: self.packages.${system}.dockerImage);