diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 18 |
1 files changed, 18 insertions, 0 deletions
@@ -157,6 +157,7 @@ nixUnstable = prev.nixUnstable; build-release-notes = final.buildPackages.callPackage ./maintainers/build-release-notes.nix { }; + check-headers = final.buildPackages.callPackage ./maintainers/check-headers.nix { }; clangbuildanalyzer = final.buildPackages.callPackage ./misc/clangbuildanalyzer.nix { }; default-busybox-sandbox-shell = final.busybox.override { @@ -353,6 +354,23 @@ ${lib.getExe pkgs.build-release-notes} doc/manual/rl-next doc/manual/rl-next-dev ''; }; + check-headers = { + enable = true; + package = pkgs.check-headers; + files = "^src/"; + types = [ + "c++" + "file" + "header" + ]; + # generated files; these will never actually be seen by this + # check, and are left here as documentation + excludes = [ + "(parser|lexer)-tab\\.hh$" + "\\.gen\\.hh$" + ]; + entry = lib.getExe pkgs.check-headers; + }; # TODO: Once the test suite is nicer, clean up and start # enforcing trailing whitespace on tests that don't explicitly # check for it. |