aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index f4fae2a00..a96aed490 100644
--- a/flake.nix
+++ b/flake.nix
@@ -547,9 +547,9 @@
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
installTests = self.hydraJobs.installTests.${system};
- } // (if system == "x86_64-linux" then {
+ } // (nixpkgs.lib.optionalAttrs (builtins.elem system linux64BitSystems)) {
dockerImage = self.hydraJobs.dockerImage.${system};
- } else {}));
+ });
packages = forAllSystems (system: {
inherit (nixpkgsFor.${system}) nix;