aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 4 insertions, 39 deletions
diff --git a/flake.nix b/flake.nix
index a22964023..beaeabcd2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -475,45 +475,10 @@
hardeningDisable = lib.optional stdenv.hostPlatform.isStatic "pie";
- passthru.perl-bindings = with final; perl.pkgs.toPerlModule (currentStdenv.mkDerivation {
- name = "nix-perl-${version}";
-
- src = fileset.toSource {
- root = ./.;
- fileset = fileset.intersect baseFiles (fileset.unions [
- ./perl
- ./.version
- ./m4
- ./mk
- ]);
- };
-
- nativeBuildInputs =
- [ buildPackages.autoconf-archive
- buildPackages.autoreconfHook
- buildPackages.pkg-config
- ];
-
- buildInputs =
- [ nix
- curl
- bzip2
- xz
- pkgs.perl
- boost
- ]
- ++ lib.optional (currentStdenv.isLinux || currentStdenv.isDarwin) libsodium
- ++ lib.optional currentStdenv.isDarwin darwin.apple_sdk.frameworks.Security;
-
- configureFlags = [
- "--with-dbi=${perlPackages.DBI}/${pkgs.perl.libPrefix}"
- "--with-dbd-sqlite=${perlPackages.DBDSQLite}/${pkgs.perl.libPrefix}"
- ];
-
- enableParallelBuilding = true;
-
- postUnpack = "sourceRoot=$sourceRoot/perl";
- });
+ passthru.perl-bindings = final.callPackage ./perl {
+ inherit fileset;
+ stdenv = currentStdenv;
+ };
meta.platforms = lib.platforms.unix;
});