aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 9b737b850..5f77e42d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -259,11 +259,11 @@
# 'nix.perl-bindings' packages.
overlay = final: prev: {
- # An older version of Nix to test against when using the daemon.
- # Currently using `nixUnstable` as the stable one doesn't respect
- # `NIX_DAEMON_SOCKET_PATH` which is needed for the tests.
nixStable = prev.nix;
+ # Forward from the previous stage as we don’t want it to pick the lowdown override
+ nixUnstable = prev.nixUnstable;
+
nix = with final; with commonDeps pkgs; stdenv.mkDerivation {
name = "nix-${version}";
inherit version;