aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 92d7b6b05..4e8b8ddb1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,13 @@
{
description = "The purely functional package manager";
- inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05-small";
+ # TODO Go back to nixos-23.05-small once
+ # https://github.com/NixOS/nixpkgs/pull/271202 is merged.
+ #
+ # Also, do not grab arbitrary further staging commits. This PR was
+ # carefully made to be based on release-23.05 and just contain
+ # rebuild-causing changes to packages that Nix actually uses.
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/staging-23.05";
inputs.nixpkgs-regression.url = "github:NixOS/nixpkgs/215d4d0fd80ca5163643b03a33fde804a29cc1e2";
inputs.lowdown-src = { url = "github:kristapsdz/lowdown"; flake = false; };
inputs.flake-compat = { url = "github:edolstra/flake-compat"; flake = false; };