aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 662469479..46f9e43e8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -99,9 +99,10 @@
];
stdenvs = [
- "gccStdenv"
+ # see assertion in package.nix why these two are disabled
+ # "stdenv"
+ # "gccStdenv"
"clangStdenv"
- "stdenv"
"libcxxStdenv"
"ccacheStdenv"
];
@@ -121,7 +122,11 @@
name = "${stdenvName}Packages";
value = f stdenvName;
}) stdenvs
- );
+ )
+ // {
+ # TODO delete this and reënable gcc stdenvs once gcc compiles kj coros correctly
+ stdenvPackages = f "clangStdenv";
+ };
# Memoize nixpkgs for different platforms for efficiency.
nixpkgsFor = forAllSystems (