aboutsummaryrefslogtreecommitdiff
path: root/misc/pegtl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'misc/pegtl.nix')
-rw-r--r--misc/pegtl.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/misc/pegtl.nix b/misc/pegtl.nix
new file mode 100644
index 000000000..3fd999d9d
--- /dev/null
+++ b/misc/pegtl.nix
@@ -0,0 +1,23 @@
+{
+ stdenv,
+ cmake,
+ ninja,
+ fetchFromGitHub,
+}:
+
+stdenv.mkDerivation {
+ pname = "pegtl";
+ version = "3.2.7";
+
+ src = fetchFromGitHub {
+ repo = "PEGTL";
+ owner = "taocpp";
+ rev = "refs/tags/3.2.7";
+ hash = "sha256-IV5YNGE4EWVrmg2Sia/rcU8jCuiBynQGJM6n3DCWTQU=";
+ };
+
+ nativeBuildInputs = [
+ cmake
+ ninja
+ ];
+}