aboutsummaryrefslogtreecommitdiff
path: root/src/libexpr/primops/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'src/libexpr/primops/derivation.nix')
-rw-r--r--src/libexpr/primops/derivation.nix38
1 files changed, 23 insertions, 15 deletions
diff --git a/src/libexpr/primops/derivation.nix b/src/libexpr/primops/derivation.nix
index c0fbe8082..674408c6d 100644
--- a/src/libexpr/primops/derivation.nix
+++ b/src/libexpr/primops/derivation.nix
@@ -1,27 +1,35 @@
-/* This is the implementation of the ‘derivation’ builtin function.
- It's actually a wrapper around the ‘derivationStrict’ primop. */
+/*
+ This is the implementation of the ‘derivation’ builtin function.
+ It's actually a wrapper around the ‘derivationStrict’ primop.
+*/
-drvAttrs @ { outputs ? [ "out" ], ... }:
+drvAttrs@{
+ outputs ? [ "out" ],
+ ...
+}:
let
strict = derivationStrict drvAttrs;
- commonAttrs = drvAttrs // (builtins.listToAttrs outputsList) //
- { all = map (x: x.value) outputsList;
+ commonAttrs =
+ drvAttrs
+ // (builtins.listToAttrs outputsList)
+ // {
+ all = map (x: x.value) outputsList;
inherit drvAttrs;
};
- outputToAttrListElement = outputName:
- { name = outputName;
- value = commonAttrs // {
- outPath = builtins.getAttr outputName strict;
- drvPath = strict.drvPath;
- type = "derivation";
- inherit outputName;
- };
+ outputToAttrListElement = outputName: {
+ name = outputName;
+ value = commonAttrs // {
+ outPath = builtins.getAttr outputName strict;
+ drvPath = strict.drvPath;
+ type = "derivation";
+ inherit outputName;
};
+ };
outputsList = map outputToAttrListElement outputs;
-
-in (builtins.head outputsList).value
+in
+(builtins.head outputsList).value