aboutsummaryrefslogtreecommitdiff
path: root/tests/check-refs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check-refs.nix')
-rw-r--r--tests/check-refs.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/check-refs.nix b/tests/check-refs.nix
index 9d90b0920..99d69a226 100644
--- a/tests/check-refs.nix
+++ b/tests/check-refs.nix
@@ -67,4 +67,11 @@ rec {
disallowedReferences = [test5];
};
+ test11 = makeTest 11 {
+ __structuredAttrs = true;
+ unsafeDiscardReferences.out = true;
+ outputChecks.out.allowedReferences = [];
+ buildCommand = ''echo ${dep} > "''${outputs[out]}"'';
+ };
+
}