aboutsummaryrefslogtreecommitdiff
path: root/tests/dyn-drv/old-daemon-error-hack.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/dyn-drv/old-daemon-error-hack.nix')
-rw-r--r--tests/dyn-drv/old-daemon-error-hack.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/dyn-drv/old-daemon-error-hack.nix b/tests/dyn-drv/old-daemon-error-hack.nix
new file mode 100644
index 000000000..c9d4a62d4
--- /dev/null
+++ b/tests/dyn-drv/old-daemon-error-hack.nix
@@ -0,0 +1,20 @@
+with import ./config.nix;
+
+# A simple content-addressed derivation.
+# The derivation can be arbitrarily modified by passing a different `seed`,
+# but the output will always be the same
+rec {
+ stub = mkDerivation {
+ name = "stub";
+ buildCommand = ''
+ echo stub > $out
+ '';
+ };
+ wrapper = mkDerivation {
+ name = "has-dynamic-drv-dep";
+ buildCommand = ''
+ exit 1 # we're not building this derivation
+ ${builtins.outputOf stub.outPath "out"}
+ '';
+ };
+}