aboutsummaryrefslogtreecommitdiff
path: root/tests/dyn-drv/text-hashed-output.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/dyn-drv/text-hashed-output.nix')
-rw-r--r--tests/dyn-drv/text-hashed-output.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/dyn-drv/text-hashed-output.nix b/tests/dyn-drv/text-hashed-output.nix
index a700fd102..99203b518 100644
--- a/tests/dyn-drv/text-hashed-output.nix
+++ b/tests/dyn-drv/text-hashed-output.nix
@@ -12,9 +12,6 @@ rec {
mkdir -p $out
echo "Hello World" > $out/hello
'';
- __contentAddressed = true;
- outputHashMode = "recursive";
- outputHashAlgo = "sha256";
};
producingDrv = mkDerivation {
name = "hello.drv";
@@ -26,4 +23,11 @@ rec {
outputHashMode = "text";
outputHashAlgo = "sha256";
};
+ wrapper = mkDerivation {
+ name = "use-dynamic-drv-in-non-dynamic-drv";
+ buildCommand = ''
+ echo "Copying the output of the dynamic derivation"
+ cp -r ${builtins.outputOf producingDrv.outPath "out"} $out
+ '';
+ };
}