aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/dependencies.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/dependencies.nix')
-rw-r--r--tests/functional/dependencies.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/tests/functional/dependencies.nix b/tests/functional/dependencies.nix
new file mode 100644
index 000000000..be1a7ae9a
--- /dev/null
+++ b/tests/functional/dependencies.nix
@@ -0,0 +1,48 @@
+{ hashInvalidator ? "" }:
+with import ./config.nix;
+
+let {
+
+ input0 = mkDerivation {
+ name = "dependencies-input-0";
+ buildCommand = "mkdir $out; echo foo > $out/bar";
+ };
+
+ input1 = mkDerivation {
+ name = "dependencies-input-1";
+ buildCommand = "mkdir $out; echo FOO > $out/foo";
+ };
+
+ input2 = mkDerivation {
+ name = "dependencies-input-2";
+ buildCommand = ''
+ mkdir $out
+ echo BAR > $out/bar
+ echo ${input0} > $out/input0
+ '';
+ };
+
+ fod_input = mkDerivation {
+ name = "fod-input";
+ buildCommand = ''
+ echo ${hashInvalidator}
+ echo FOD > $out
+ '';
+ outputHashMode = "flat";
+ outputHashAlgo = "sha256";
+ outputHash = "1dq9p0hnm1y75q2x40fws5887bq1r840hzdxak0a9djbwvx0b16d";
+ };
+
+ body = mkDerivation {
+ name = "dependencies-top";
+ builder = ./dependencies.builder0.sh + "/FOOBAR/../.";
+ input1 = input1 + "/.";
+ input2 = "${input2}/.";
+ input1_drv = input1;
+ input2_drv = input2;
+ input0_drv = input0;
+ fod_input_drv = fod_input;
+ meta.description = "Random test package";
+ };
+
+}