aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/export-graph.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/export-graph.nix')
-rw-r--r--tests/functional/export-graph.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/functional/export-graph.nix b/tests/functional/export-graph.nix
new file mode 100644
index 000000000..64fe36bd1
--- /dev/null
+++ b/tests/functional/export-graph.nix
@@ -0,0 +1,29 @@
+with import ./config.nix;
+
+rec {
+
+ printRefs =
+ ''
+ echo $exportReferencesGraph
+ while read path; do
+ read drv
+ read nrRefs
+ echo "$path has $nrRefs references"
+ echo "$path" >> $out
+ for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; test -e "$ref"; done
+ done < refs
+ '';
+
+ foo."bar.runtimeGraph" = mkDerivation {
+ name = "dependencies";
+ builder = builtins.toFile "build-graph-builder" "${printRefs}";
+ exportReferencesGraph = ["refs" (import ./dependencies.nix {})];
+ };
+
+ foo."bar.buildGraph" = mkDerivation {
+ name = "dependencies";
+ builder = builtins.toFile "build-graph-builder" "${printRefs}";
+ exportReferencesGraph = ["refs" (import ./dependencies.nix {}).drvPath];
+ };
+
+}