aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/gc-concurrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/gc-concurrent.nix')
-rw-r--r--tests/functional/gc-concurrent.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/functional/gc-concurrent.nix b/tests/functional/gc-concurrent.nix
new file mode 100644
index 000000000..0aba1f983
--- /dev/null
+++ b/tests/functional/gc-concurrent.nix
@@ -0,0 +1,30 @@
+with import ./config.nix;
+
+{ lockFifo ? null }:
+
+rec {
+
+ input1 = mkDerivation {
+ name = "dependencies-input-1";
+ buildCommand = "mkdir $out; echo FOO > $out/foo";
+ };
+
+ input2 = mkDerivation {
+ name = "dependencies-input-2";
+ buildCommand = "mkdir $out; echo BAR > $out/bar";
+ };
+
+ test1 = mkDerivation {
+ name = "gc-concurrent";
+ builder = ./gc-concurrent.builder.sh;
+ inherit input1 input2;
+ inherit lockFifo;
+ };
+
+ test2 = mkDerivation {
+ name = "gc-concurrent2";
+ builder = ./gc-concurrent2.builder.sh;
+ inherit input1 input2;
+ };
+
+}