aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/gc-runtime.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/gc-runtime.nix')
-rw-r--r--tests/functional/gc-runtime.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/functional/gc-runtime.nix b/tests/functional/gc-runtime.nix
new file mode 100644
index 000000000..ee5980bdf
--- /dev/null
+++ b/tests/functional/gc-runtime.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+mkDerivation {
+ name = "gc-runtime";
+ builder =
+ # Test inline source file definitions.
+ builtins.toFile "builder.sh" ''
+ mkdir $out
+
+ cat > $out/program <<EOF
+ #! ${shell}
+ sleep 10000
+ EOF
+
+ chmod +x $out/program
+ '';
+}