aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/hash-check.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/hash-check.nix')
-rw-r--r--tests/functional/hash-check.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/functional/hash-check.nix b/tests/functional/hash-check.nix
new file mode 100644
index 000000000..4a8e9b8a8
--- /dev/null
+++ b/tests/functional/hash-check.nix
@@ -0,0 +1,29 @@
+let {
+
+ input1 = derivation {
+ name = "dependencies-input-1";
+ system = "i086-msdos";
+ builder = "/bar/sh";
+ args = ["-e" "-x" ./dummy];
+ };
+
+ input2 = derivation {
+ name = "dependencies-input-2";
+ system = "i086-msdos";
+ builder = "/bar/sh";
+ args = ["-e" "-x" ./dummy];
+ outputHashMode = "recursive";
+ outputHashAlgo = "md5";
+ outputHash = "ffffffffffffffffffffffffffffffff";
+ };
+
+ body = derivation {
+ name = "dependencies";
+ system = "i086-msdos";
+ builder = "/bar/sh";
+ args = ["-e" "-x" (./dummy + "/FOOBAR/../.")];
+ input1 = input1 + "/.";
+ inherit input2;
+ };
+
+} \ No newline at end of file