aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix')
-rw-r--r--tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix b/tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix
new file mode 100644
index 000000000..1620cc76e
--- /dev/null
+++ b/tests/functional/lang/eval-fail-foldlStrict-strict-op-application.nix
@@ -0,0 +1,5 @@
+# Tests that the result of applying op is forced even if the value is never used
+builtins.foldl'
+ (_: f: f null)
+ null
+ [ (_: throw "Not the final value, but is still forced!") (_: 23) ]