aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-any-all.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-any-all.nix')
-rw-r--r--tests/functional/lang/eval-okay-any-all.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-any-all.nix b/tests/functional/lang/eval-okay-any-all.nix
new file mode 100644
index 000000000..a3f26ea2a
--- /dev/null
+++ b/tests/functional/lang/eval-okay-any-all.nix
@@ -0,0 +1,11 @@
+with builtins;
+
+[ (any (x: x == 1) [])
+ (any (x: x == 1) [2 3 4])
+ (any (x: x == 1) [1 2 3 4])
+ (any (x: x == 1) [4 3 2 1])
+ (all (x: x == 1) [])
+ (all (x: x == 1) [1])
+ (all (x: x == 1) [1 2 3])
+ (all (x: x == 1) [1 1 1])
+]