aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-arithmetic.nix')
-rw-r--r--tests/functional/lang/eval-okay-arithmetic.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/functional/lang/eval-okay-arithmetic.nix b/tests/functional/lang/eval-okay-arithmetic.nix
index 7e9e6a0b6..534e9d169 100644
--- a/tests/functional/lang/eval-okay-arithmetic.nix
+++ b/tests/functional/lang/eval-okay-arithmetic.nix
@@ -1,6 +1,6 @@
with import ./lib.nix;
-let {
+let
/* Supposedly tail recursive version:
@@ -15,7 +15,8 @@ let {
err = abort "urgh";
- body = sum
+in
+ sum
[ (sum (range 1 50))
(123 + 456)
(0 + -10 + -(-11) + -x)
@@ -54,6 +55,5 @@ let {
(if "aa" < "ab" then 1 else err)
(if "aa" < "aa" then err else 1)
(if "foo" < "foobar" then 1 else err)
- ];
+ ]
-}