aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-attrs3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-attrs3.nix')
-rw-r--r--tests/functional/lang/eval-okay-attrs3.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-attrs3.nix b/tests/functional/lang/eval-okay-attrs3.nix
new file mode 100644
index 000000000..f29de11fe
--- /dev/null
+++ b/tests/functional/lang/eval-okay-attrs3.nix
@@ -0,0 +1,22 @@
+let
+
+ config =
+ {
+ services.sshd.enable = true;
+ services.sshd.port = 22;
+ services.httpd.port = 80;
+ hostName = "itchy";
+ a.b.c.d.e.f.g.h.i.j.k.l.m.n.o.p.q.r.s.t.u.v.w.x.y.z = "x";
+ foo = {
+ a = "a";
+ b.c = "c";
+ };
+ };
+
+in
+ if config.services.sshd.enable
+ then "foo ${toString config.services.sshd.port} ${toString config.services.httpd.port} ${config.hostName}"
+ + "${config.a.b.c.d.e.f.g.h.i.j.k.l.m.n.o.p.q.r.s.t.u.v.w.x.y.z}"
+ + "${config.foo.a}"
+ + "${config.foo.b.c}"
+ else "bar"