aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-concatmap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-concatmap.nix')
-rw-r--r--tests/functional/lang/eval-okay-concatmap.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-concatmap.nix b/tests/functional/lang/eval-okay-concatmap.nix
new file mode 100644
index 000000000..97da5d37a
--- /dev/null
+++ b/tests/functional/lang/eval-okay-concatmap.nix
@@ -0,0 +1,5 @@
+with import ./lib.nix;
+
+[ (builtins.concatMap (x: if x / 2 * 2 == x then [] else [ x ]) (range 0 10))
+ (builtins.concatMap (x: [x] ++ ["z"]) ["a" "b"])
+]