aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-float.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-float.nix')
-rw-r--r--tests/functional/lang/eval-okay-float.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-float.nix b/tests/functional/lang/eval-okay-float.nix
new file mode 100644
index 000000000..b2702c7b1
--- /dev/null
+++ b/tests/functional/lang/eval-okay-float.nix
@@ -0,0 +1,6 @@
+[
+ (1.1 + 2.3)
+ (builtins.add (0.5 + 0.5) (2.0 + 0.5))
+ ((0.5 + 0.5) * (2.0 + 0.5))
+ ((1.5 + 1.5) / (0.5 * 4.0))
+]