aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-inherit-from.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-inherit-from.nix')
-rw-r--r--tests/functional/lang/eval-okay-inherit-from.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-inherit-from.nix b/tests/functional/lang/eval-okay-inherit-from.nix
new file mode 100644
index 000000000..d1fad7d69
--- /dev/null
+++ b/tests/functional/lang/eval-okay-inherit-from.nix
@@ -0,0 +1,6 @@
+let
+ inherit (builtins.trace "used" { a = 1; b = 2; }) a b;
+ x.c = 3;
+ y.d = 4;
+in
+ [ a b rec { x.c = []; inherit (x) c; inherit (y) d; __overrides.y.d = []; } ]