aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-new-let.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-new-let.nix')
-rw-r--r--tests/functional/lang/eval-okay-new-let.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-new-let.nix b/tests/functional/lang/eval-okay-new-let.nix
new file mode 100644
index 000000000..738123141
--- /dev/null
+++ b/tests/functional/lang/eval-okay-new-let.nix
@@ -0,0 +1,14 @@
+let
+
+ f = z:
+
+ let
+ x = "foo";
+ y = "bar";
+ body = 1; # compat test
+ in
+ z + x + y;
+
+ arg = "xyzzy";
+
+in f arg