aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-search-path.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-search-path.nix')
-rw-r--r--tests/functional/lang/eval-okay-search-path.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-search-path.nix b/tests/functional/lang/eval-okay-search-path.nix
new file mode 100644
index 000000000..6fe33decc
--- /dev/null
+++ b/tests/functional/lang/eval-okay-search-path.nix
@@ -0,0 +1,10 @@
+with import ./lib.nix;
+with builtins;
+
+assert isFunction (import <nix/fetchurl.nix>);
+
+assert length __nixPath == 5;
+assert length (filter (x: baseNameOf x.path == "dir4") __nixPath) == 1;
+
+import <a.nix> + import <b.nix> + import <c.nix> + import <dir5/c.nix>
+ + (let __nixPath = [ { path = ./dir2; } { path = ./dir1; } ]; in import <a.nix>)