aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-strings-as-attrs-names.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-strings-as-attrs-names.nix')
-rw-r--r--tests/functional/lang/eval-okay-strings-as-attrs-names.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-strings-as-attrs-names.nix b/tests/functional/lang/eval-okay-strings-as-attrs-names.nix
new file mode 100644
index 000000000..5e40928db
--- /dev/null
+++ b/tests/functional/lang/eval-okay-strings-as-attrs-names.nix
@@ -0,0 +1,20 @@
+let
+
+ attr = {
+ "key 1" = "test";
+ "key 2" = "caseok";
+ };
+
+ t1 = builtins.getAttr "key 1" attr;
+ t2 = attr."key 2";
+ t3 = attr ? "key 1";
+ t4 = builtins.attrNames { inherit (attr) "key 1"; };
+
+ # This is permitted, but there is currently no way to reference this
+ # variable.
+ "foo bar" = 1;
+
+in t1 == "test"
+ && t2 == "caseok"
+ && t3 == true
+ && t4 == ["key 1"]