aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-tojson.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-tojson.nix')
-rw-r--r--tests/functional/lang/eval-okay-tojson.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-tojson.nix b/tests/functional/lang/eval-okay-tojson.nix
new file mode 100644
index 000000000..ce67943be
--- /dev/null
+++ b/tests/functional/lang/eval-okay-tojson.nix
@@ -0,0 +1,13 @@
+builtins.toJSON
+ { a = 123;
+ b = -456;
+ c = "foo";
+ d = "foo\n\"bar\"";
+ e = true;
+ f = false;
+ g = [ 1 2 3 ];
+ h = [ "a" [ "b" { "foo\nbar" = {}; } ] ];
+ i = 1 + 2;
+ j = 1.44;
+ k = { __toString = self: self.a; a = "foo"; };
+ }