aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-tryeval.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-tryeval.nix')
-rw-r--r--tests/functional/lang/eval-okay-tryeval.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-tryeval.nix b/tests/functional/lang/eval-okay-tryeval.nix
new file mode 100644
index 000000000..629bc440a
--- /dev/null
+++ b/tests/functional/lang/eval-okay-tryeval.nix
@@ -0,0 +1,5 @@
+{
+ x = builtins.tryEval "x";
+ y = builtins.tryEval (assert false; "y");
+ z = builtins.tryEval (throw "bla");
+}