aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-types.nix')
-rw-r--r--tests/functional/lang/eval-okay-types.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-types.nix b/tests/functional/lang/eval-okay-types.nix
new file mode 100644
index 000000000..9b58be5d1
--- /dev/null
+++ b/tests/functional/lang/eval-okay-types.nix
@@ -0,0 +1,37 @@
+with builtins;
+
+[ (isNull null)
+ (isNull (x: x))
+ (isFunction (x: x))
+ (isFunction "fnord")
+ (isString ("foo" + "bar"))
+ (isString [ "x" ])
+ (isInt (1 + 2))
+ (isInt { x = 123; })
+ (isInt (1 / 2))
+ (isInt (1 + 1))
+ (isInt (1 / 2))
+ (isInt (1 * 2))
+ (isInt (1 - 2))
+ (isFloat (1.2))
+ (isFloat (1 + 1.0))
+ (isFloat (1 / 2.0))
+ (isFloat (1 * 2.0))
+ (isFloat (1 - 2.0))
+ (isBool (true && false))
+ (isBool null)
+ (isPath /nix/store)
+ (isPath ./.)
+ (isAttrs { x = 123; })
+ (isAttrs null)
+ (typeOf (3 * 4))
+ (typeOf true)
+ (typeOf "xyzzy")
+ (typeOf null)
+ (typeOf { x = 456; })
+ (typeOf [ 1 2 3 ])
+ (typeOf (x: x))
+ (typeOf ((x: y: x) 1))
+ (typeOf map)
+ (typeOf (map (x: x)))
+]