aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-xml.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-xml.nix')
-rw-r--r--tests/functional/lang/eval-okay-xml.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-xml.nix b/tests/functional/lang/eval-okay-xml.nix
new file mode 100644
index 000000000..9ee9f8a0b
--- /dev/null
+++ b/tests/functional/lang/eval-okay-xml.nix
@@ -0,0 +1,21 @@
+rec {
+
+ x = 123;
+
+ y = 567.890;
+
+ a = "foo";
+
+ b = "bar";
+
+ c = "foo" + "bar";
+
+ f = {z, x, y}: if y then x else z;
+
+ id = x: x;
+
+ at = args@{x, y, z}: x;
+
+ ellipsis = {x, y, z, ...}: x;
+
+}