aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/simple-failing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/simple-failing.nix')
-rw-r--r--tests/functional/simple-failing.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/functional/simple-failing.nix b/tests/functional/simple-failing.nix
new file mode 100644
index 000000000..d176c9c51
--- /dev/null
+++ b/tests/functional/simple-failing.nix
@@ -0,0 +1,12 @@
+with import ./config.nix;
+
+mkDerivation {
+ name = "simple-failing";
+ builder = builtins.toFile "builder.sh"
+ ''
+ echo "This should fail"
+ exit 1
+ '';
+ PATH = "";
+ goodPath = path;
+}