aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/timeout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/timeout.nix')
-rw-r--r--tests/functional/timeout.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/functional/timeout.nix b/tests/functional/timeout.nix
new file mode 100644
index 000000000..d0e949e31
--- /dev/null
+++ b/tests/functional/timeout.nix
@@ -0,0 +1,31 @@
+with import ./config.nix;
+
+{
+
+ infiniteLoop = mkDerivation {
+ name = "timeout";
+ buildCommand = ''
+ touch $out
+ echo "'timeout' builder entering an infinite loop"
+ while true ; do echo -n .; done
+ '';
+ };
+
+ silent = mkDerivation {
+ name = "silent";
+ buildCommand = ''
+ touch $out
+ sleep 60
+ '';
+ };
+
+ closeLog = mkDerivation {
+ name = "silent";
+ buildCommand = ''
+ touch $out
+ exec > /dev/null 2>&1
+ sleep 1000000000
+ '';
+ };
+
+}