aboutsummaryrefslogtreecommitdiff
path: root/tests/functional2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional2/meson.build')
-rw-r--r--tests/functional2/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/functional2/meson.build b/tests/functional2/meson.build
new file mode 100644
index 000000000..590f11dd9
--- /dev/null
+++ b/tests/functional2/meson.build
@@ -0,0 +1,19 @@
+# surprisingly, this actually works even if PATH is set to something before
+# meson gets hold of it. neat!
+functional2_env = environment()
+functional2_env.prepend('PATH', bindir)
+
+test(
+ 'functional2',
+ python,
+ args : [
+ '-m', 'pytest', meson.current_source_dir()
+ ],
+ env : functional2_env,
+ # FIXME: Although we can trivially use TAP here with pytest-tap, due to a meson bug, it is unusable.
+ # (failure output does not get displayed to the console. at all. someone should go fix it):
+ # https://github.com/mesonbuild/meson/issues/11185
+ # protocol : 'tap',
+ suite : 'installcheck',
+ timeout : 300,
+)