aboutsummaryrefslogtreecommitdiff
path: root/tests/nix-copy-closure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nix-copy-closure.nix')
-rw-r--r--tests/nix-copy-closure.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/nix-copy-closure.nix b/tests/nix-copy-closure.nix
index db6103b9c..ca09dffac 100644
--- a/tests/nix-copy-closure.nix
+++ b/tests/nix-copy-closure.nix
@@ -13,14 +13,14 @@ makeTest ({ pkgs, ... }: let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
virtualisation.pathsInNixDB = [ pkgA ];
environment.nix = nix;
};
-
+
server =
{ config, pkgs, ... }:
{ services.openssh.enable = true;
virtualisation.writableStore = true;
virtualisation.pathsInNixDB = [ pkgB ];
environment.nix = nix;
- };
+ };
};
testScript = { nodes }:
@@ -36,8 +36,8 @@ makeTest ({ pkgs, ... }: let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
# Install the SSH key on the server.
$server->succeed("mkdir -m 700 /root/.ssh");
$server->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
- $server->waitForJob("sshd");
- $client->waitForJob("network-interfaces");
+ $server->waitForUnit("sshd");
+ $client->waitForUnit("network.target");
$client->succeed("ssh -o StrictHostKeyChecking=no " . $server->name() . " 'echo hello world'");
# Copy the closure of package A from the client to the server.