aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/nix-copy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nixos/nix-copy.nix')
-rw-r--r--tests/nixos/nix-copy.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/nixos/nix-copy.nix b/tests/nixos/nix-copy.nix
index 16c477bf9..ef053de03 100644
--- a/tests/nixos/nix-copy.nix
+++ b/tests/nixos/nix-copy.nix
@@ -79,6 +79,15 @@ in {
server.copy_from_host("key.pub", "/root/.ssh/authorized_keys")
server.succeed("systemctl restart sshd")
client.succeed(f"ssh -o StrictHostKeyChecking=no {server.name} 'echo hello world'")
+ client.succeed(f"ssh -O check {server.name}")
+ client.succeed(f"ssh -O exit {server.name}")
+ client.fail(f"ssh -O check {server.name}")
+
+ # Check that an explicit master will work
+ client.succeed(f"ssh -MNfS /tmp/master {server.name}")
+ client.succeed(f"ssh -S /tmp/master -O check {server.name}")
+ client.succeed("NIX_SSHOPTS='-oControlPath=/tmp/master' nix copy --to ssh://server ${pkgA} >&2")
+ client.succeed(f"ssh -S /tmp/master -O exit {server.name}")
# Copy the closure of package B from the server to the client, using ssh-ng.
client.fail("nix-store --check-validity ${pkgB}")