aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index 7b2e6f708..9f88217fe 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -16,7 +16,7 @@ let
{ config, pkgs, ... }:
{ services.openssh.enable = true;
virtualisation.writableStore = true;
- nix.useSandbox = true;
+ nix.settings.sandbox = true;
};
# Trivial Nix expression to build remotely.
@@ -44,7 +44,7 @@ in
client =
{ config, lib, pkgs, ... }:
- { nix.maxJobs = 0; # force remote building
+ { nix.settings.max-jobs = 0; # force remote building
nix.distributedBuilds = true;
nix.buildMachines =
[ { hostName = "builder1";
@@ -62,7 +62,7 @@ in
];
virtualisation.writableStore = true;
virtualisation.additionalPaths = [ config.system.build.extraUtils ];
- nix.binaryCaches = lib.mkForce [ ];
+ nix.settings.substituters = lib.mkForce [ ];
programs.ssh.extraConfig = "ConnectTimeout 30";
};
};