aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index b0d2547c6..6d38fb568 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -72,11 +72,11 @@ in
$client->succeed("chmod 600 /root/.ssh/id_dsa");
# Install the SSH key on the slaves.
- $client->waitForJob("network-interfaces");
+ $client->waitForUnit("network.target");
foreach my $slave ($slave1, $slave2) {
$slave->succeed("mkdir -m 700 /root/.ssh");
$slave->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
- $slave->waitForJob("sshd");
+ $slave->waitForUnit("sshd");
$client->succeed("ssh -o StrictHostKeyChecking=no " . $slave->name() . " 'echo hello world'");
}