aboutsummaryrefslogtreecommitdiff
path: root/tests/setuid.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/setuid.nix')
-rw-r--r--tests/setuid.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/setuid.nix b/tests/setuid.nix
index 35eb304ed..82efd6d54 100644
--- a/tests/setuid.nix
+++ b/tests/setuid.nix
@@ -10,12 +10,12 @@ with import (nixpkgs + "/nixos/lib/testing-python.nix") {
makeTest {
name = "setuid";
- machine =
+ nodes.machine =
{ config, lib, pkgs, ... }:
{ virtualisation.writableStore = true;
- nix.binaryCaches = lib.mkForce [ ];
+ nix.settings.substituters = lib.mkForce [ ];
nix.nixPath = [ "nixpkgs=${lib.cleanSource pkgs.path}" ];
- virtualisation.pathsInNixDB = [ pkgs.stdenv pkgs.pkgsi686Linux.stdenv ];
+ virtualisation.additionalPaths = [ pkgs.stdenv pkgs.pkgsi686Linux.stdenv ];
};
testScript = { nodes }: ''