aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index eb39f9039..6cb4f082b 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -1,4 +1,4 @@
-{ }:
+{ inNixShell ? false }:
with import ./config.nix;
@@ -22,6 +22,7 @@ let pkgs = rec {
name = "shellDrv";
builder = "/does/not/exist";
VAR_FROM_NIX = "bar";
+ TEST_inNixShell = if inNixShell then "true" else "false";
inherit stdenv;
};