aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index 24ebcc04c..53a32059b 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -8,6 +8,14 @@ let pkgs = rec {
for pkg in $buildInputs; do
export PATH=$PATH:$pkg/bin
done
+
+ # mimic behavior of stdenv for `$out` etc. for structured attrs.
+ if [ -n "''${ATTRS_SH_FILE}" ]; then
+ for o in "''${!outputs[@]}"; do
+ eval "''${o}=''${outputs[$o]}"
+ export "''${o}"
+ done
+ fi
'';
stdenv = mkDerivation {