aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index c3eefeede..9f19e5fd9 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -249,3 +249,25 @@ test(
suite : 'check',
protocol : 'gtest',
)
+
+libmain_tester = executable(
+ 'liblixmain-tests',
+ files('libmain/progress-bar.cc'),
+ dependencies : [
+ liblixmain,
+ liblixexpr,
+ liblixutil,
+ liblixstore,
+ gtest,
+ boost,
+ ],
+ cpp_pch : cpp_pch,
+)
+
+test(
+ 'libmain-unit-tests',
+ libmain_tester,
+ args : tests_args,
+ suite : 'check',
+ protocol : 'gtest',
+)