aboutsummaryrefslogtreecommitdiff
path: root/nix-personal/configuration.nix
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-12-05 20:53:17 +0000
committerAria <me@aria.rip>2023-12-05 20:53:17 +0000
commit143c6f152e96214b4c75c31047a1eda0cd51513a (patch)
treed721752bac45d0993ef24aa7cfcccdd19aae1638 /nix-personal/configuration.nix
parent318522a2613ec7242b2559be66b5edf466a2e5ef (diff)
own vps
Diffstat (limited to 'nix-personal/configuration.nix')
-rw-r--r--nix-personal/configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix-personal/configuration.nix b/nix-personal/configuration.nix
new file mode 100644
index 0000000..1830725
--- /dev/null
+++ b/nix-personal/configuration.nix
@@ -0,0 +1,31 @@
+{
+ modulesPath,
+ config,
+ lib,
+ pkgs,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ (modulesPath + "/profiles/qemu-guest.nix")
+ ./disk-config.nix
+ ];
+ boot.loader.grub = {
+ # no need to set devices, disko will add all devices that have a EF02 partition to the list already
+ # devices = [ ];
+ efiSupport = true;
+ efiInstallAsRemovable = true;
+ };
+ services.openssh.enable = true;
+
+ environment.systemPackages = map lib.lowPrio [
+ pkgs.curl
+ pkgs.gitMinimal
+ ];
+
+ users.users.root.openssh.authorizedKeys.keys = [
+ "sk-ssh-ed25519@openssh.com AAAAGnNrLXNzaC1lZDI1NTE5QG9wZW5zc2guY29tAAAAIPKawhXHIFl+j/YciUzfT6AkuhLJQ9hwFU8Jl07bC7XqAAAABHNzaDo= me@aria.rip"
+ ];
+
+ system.stateVersion = "23.11";
+}